#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^visite\d+\b"
Local $sString = "visite12345" & @CRLF & _
" --> is a good anwser (the string does match)" & @CRLF & _
"visite1a" & @CRLF & _
" --> is not a good anwser (the string doesn't match)" & @CRLF & _
"visite12345a" & @CRLF & _
" --> It doesn't work.the output is visite1234, whereas I'd like to get the same answer that for visite1a (string doesn't match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")