package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^visite\d+\b`)
var str = `visite12345
--> is a good anwser (the string does match)
visite1a
--> is not a good anwser (the string doesn't match)
visite12345a
--> It doesn't work.the output is visite1234, whereas I'd like to get the same answer that for visite1a (string doesn't match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}