using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/([0-9]{6})((?!.*\.php(?:[\?#].*|$)).*)$";
string input = @"/002030/sdfsdfgdfgfgdphpd";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}