$re = '/^\/([0-9]{6})((?!.*\.php(?:[\?#].*|$)).*)$/';
$str = '/002030/sdfsdfgdfgfgdphpd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);