re = /^\/([0-9]{6})((?!.*\.php(?:[\?#].*|$)).*)$/
str = '/002030/sdfsdfgdfgfgdphpd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end