#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([0-9]+.?[0-9]*|[0-9]*.?[0-9]+)(["\'])?$"
Local $sString = "2" & @CRLF & _
"2.2" & @CRLF & _
"2"" & @CRLF & _
"2'" & @CRLF & _
"2.3"" & @CRLF & _
"2.4"" & @CRLF & _
"2'" & @CRLF & _
"2." & @CRLF & _
"2'2"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")