using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9]+.?[0-9]*|[0-9]*.?[0-9]+)([""\'])?$";
string input = @"2
2.2
2""
2'
2.3""
2.4""
2'
2.
2'2""
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}