re = /^([0-9]+.?[0-9]*|[0-9]*.?[0-9]+)(["\'])?$/
str = '2
2.2
2"
2\'
2.3"
2.4"
2\'
2.
2\'2"
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end