package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{L}\p{N}._-~]+`)
var str = `զվարճ?անք9879#jhkjhkhl!kjljlkjlkjj()+======\_ew.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}