$re = '/[^\p{L}\p{N}._-~]+/mu';
$str = 'զվարճ?անք9879#jhkjhkhl!kjljlkjlkjj()+======\\_ew.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);