use strict;
my $str = '3x+1y
10x-2y
-5x+2y
-10x+5y';
my $regex = qr/^(?=.*?([+-]?[0-9]*)x)(?=.*?([+-]?[0-9]*)y)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}