re = /^(?=.*?([+-]?[0-9]*)x)(?=.*?([+-]?[0-9]*)y)/m
str = '3x+1y
10x-2y
-5x+2y
-10x+5y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end