import re
regex = re.compile(r"^(?=.*?([+-]?[0-9]*)x)(?=.*?([+-]?[0-9]*)y)", flags=re.MULTILINE)
test_str = ("3x+1y\n"
"10x-2y\n"
"-5x+2y\n"
"-10x+5y")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")