#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!QCNIL|Epic_SNA).+$"
Local $sString = "Epic_IKDH_Appt_Phone_Reminders_20191030.txt " & @CRLF & _
"Epic_NAMMI_Appt_Phone_Reminders_20191031.txt " & @CRLF & _
"QCNIL-Recall_Phone_Reminders_20191029.txt " & @CRLF & _
"Epic_SNA_Appt_No_Show_Reminders_20191029.txt" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Epic_IKDH_Appt_Phone_Reminders_20191030.txt" & @CRLF & _
"Epic_NAMMI_Appt_Phone_Reminders_20191031.txt" & @CRLF & _
"QCNIA-Recall_Phone_Reminders_20191029.txt " & @CRLF & _
"Epic_SNB_Appt_No_Show_Reminders_20191029.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")