# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!QCNIL|Epic_SNA).+$"
test_str = ("Epic_IKDH_Appt_Phone_Reminders_20191030.txt \n"
"Epic_NAMMI_Appt_Phone_Reminders_20191031.txt \n"
"QCNIL-Recall_Phone_Reminders_20191029.txt \n"
"Epic_SNA_Appt_No_Show_Reminders_20191029.txt\n\n\n"
"Epic_IKDH_Appt_Phone_Reminders_20191030.txt\n"
"Epic_NAMMI_Appt_Phone_Reminders_20191031.txt\n"
"QCNIA-Recall_Phone_Reminders_20191029.txt \n"
"Epic_SNB_Appt_No_Show_Reminders_20191029.txt")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.