import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!QCNIL|Epic_SNA).+$";
final String string = "Epic_IKDH_Appt_Phone_Reminders_20191030.txt \n"
+ "Epic_NAMMI_Appt_Phone_Reminders_20191031.txt \n"
+ "QCNIL-Recall_Phone_Reminders_20191029.txt \n"
+ "Epic_SNA_Appt_No_Show_Reminders_20191029.txt\n\n\n"
+ "Epic_IKDH_Appt_Phone_Reminders_20191030.txt\n"
+ "Epic_NAMMI_Appt_Phone_Reminders_20191031.txt\n"
+ "QCNIA-Recall_Phone_Reminders_20191029.txt \n"
+ "Epic_SNB_Appt_No_Show_Reminders_20191029.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}