import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<senhaCampo>`?senha`?(\\ *|\\s\\s*)=(\\ *|\\s\\s*))(?P<aspas>('|\\\"))(?P<senhaValue>((?!\"\\ (AND|OR|IN)).)+)(\"|')";
final String string = "\n"
+ "andre \\\n\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \" koko ro10 \\\" '''asdasd''\\\"\\\"5\" OR organizacao_id = \\\"1\\\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND (senha = \"kokoro10@\\\"5\"\"\" \"\"\"\"\"'\" OR organizacao_id = \\\"1\\\")\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND (senha = \"kokoro10@\\\"5\"\"\" \"\"\"\"\"'\" AND organizacao_id = \\\"1\\\")\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"kokoro10@\\\"5\"\"\" \"\"\"\"\"'\" IN organizacao_id = \\\"1\\\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"kokoro10@\\\"5\"\" \"\"\"\"\"\"'\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"kokor o10@\\\"5'\";\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = 'kokor o10@\"5\\''\n\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"$%\\\"''asdas!@#$%*()_)(*&$#@!\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"$%\\\"''asda s!@#$%*()_)(*&$#@!\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada, empregado, data_saida, data_deslig, data_susp\n"
+ "\\n\\t\\t\\tFROM conline.usr\n"
+ "\\n\\t\\t\\tWHERE login = \"laisajesusgonzaga.z72015@gmail.com\" AND senha = \"0633263850\\'8\\'\\'\" AND organizacao_id = \"2\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"kokoro10\\'5\" AND organizacao_id = \\\"1\\\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr \n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"kokoro10'5\" AND organizacao_id = \\\"1\\\"\n\n"
+ "SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada\n"
+ " WHEREFROM conline.usr\n"
+ " WHERE login = \\\"kennya.miiyamura@cacaushow.com.br\\\" AND senha = \"kokoro10\"5'''\" AND organizacao_id = \\\"1\\\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}