re = /(?P<senhaCampo>`?senha`?(\ *|\s\s*)=(\ *|\s\s*))(?P<aspas>('|\"))(?P<senhaValue>((?!"\ (AND|OR|IN)).)+)("|')/mi
str = '
andre \\
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = " koko ro10 \\" \'\'\'asdasd\'\'\\"\\"5" OR organizacao_id = \\"1\\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND (senha = "kokoro10@\\"5""" """""\'" OR organizacao_id = \\"1\\")
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND (senha = "kokoro10@\\"5""" """""\'" AND organizacao_id = \\"1\\")
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "kokoro10@\\"5""" """""\'" IN organizacao_id = \\"1\\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "kokoro10@\\"5"" """"""\'"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "kokor o10@\\"5\'";
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = \'kokor o10@"5\\\'\'
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "$%\\"\'\'asdas!@#$%*()_)(*&$#@!"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "$%\\"\'\'asda s!@#$%*()_)(*&$#@!"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada, empregado, data_saida, data_deslig, data_susp
\\n\\t\\t\\tFROM conline.usr
\\n\\t\\t\\tWHERE login = "laisajesusgonzaga.z72015@gmail.com" AND senha = "0633263850\\\'8\\\'\\\'" AND organizacao_id = "2"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "kokoro10\\\'5" AND organizacao_id = \\"1\\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "kokoro10\'5" AND organizacao_id = \\"1\\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \\"kennya.miiyamura@cacaushow.com.br\\" AND senha = "kokoro10"5\'\'\'" AND organizacao_id = \\"1\\"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end