import Foundation
let pattern = #"(?P<senhaCampo>`?senha`?(\ *|\s\s*)=(\ *|\s\s*))(?P<aspas>('|\"))(?P<senhaValue>((?!"\ (AND|OR|IN)).)+)("|')"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
andre \
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = " koko ro10 \" '''asdasd''\"\"5" OR organizacao_id = \"1\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND (senha = "kokoro10@\"5""" """""'" OR organizacao_id = \"1\")
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND (senha = "kokoro10@\"5""" """""'" AND organizacao_id = \"1\")
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "kokoro10@\"5""" """""'" IN organizacao_id = \"1\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "kokoro10@\"5"" """"""'"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "kokor o10@\"5'";
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = 'kokor o10@"5\''
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "$%\"''asdas!@#$%*()_)(*&$#@!"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "$%\"''asda s!@#$%*()_)(*&$#@!"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada, empregado, data_saida, data_deslig, data_susp
\n\t\t\tFROM conline.usr
\n\t\t\tWHERE login = "laisajesusgonzaga.z72015@gmail.com" AND senha = "0633263850\'8\'\'" AND organizacao_id = "2"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "kokoro10\'5" AND organizacao_id = \"1\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "kokoro10'5" AND organizacao_id = \"1\"
SELECT usr_id, emp_id, plano_id, origem_id, login, senha, status, statusemp, origem, nome, data_nasc, email, sexo, estadocivil, data_entrada
WHEREFROM conline.usr
WHERE login = \"kennya.miiyamura@cacaushow.com.br\" AND senha = "kokoro10"5'''" AND organizacao_id = \"1\"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)