package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(\d+)]`)
var str = `this is a test [1] also this [2] is a test
and again [3] this is a test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}