re = /\[(\d+)]/
str = 'this is a test [1] also this [2] is a test
and again [3] this is a test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end