$re = '/\[(\d+)]/';
$str = 'this is a test [1] also this [2] is a test
and again [3] this is a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);