const regex = new RegExp('data-reveal="(.+)', '')
const str = `<a class="button block left icon-phone" data-reveal="\\u06f0\\u06f9\\u06f3\\u06f6\\u06f5\\u06f6\\u06f8\\u06f1\\u06f6\\u06f2\\u06f1" href="#">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}