import re
regex = re.compile(r"data-reveal=\"(.+)")
test_str = "<a class=\"button block left icon-phone\" data-reveal=\"\\u06f0\\u06f9\\u06f3\\u06f6\\u06f5\\u06f6\\u06f8\\u06f1\\u06f6\\u06f2\\u06f1\" href=\"#\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")