using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\]]+)\]([^\[]+)\[\/\1\]";
string input = @"[tag1]Test's Text Test Text Test Text Test Text.
Test Text Test Text Test ""Text Test Text"" Test Text Test Text.
Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.
Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag1]
[tag2]Test's Text Test Text Test Text Test Text.
Test Text Test Text Test ""Text Test Text"" Test Text Test Text.
Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.
Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag2]
...
...
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}