re = /\[([^\]]+)\]([^\[]+)\[\/\1\]/
str = '[tag1]Test\'s Text Test Text Test Text Test Text.
Test Text Test Text Test "Text Test Text" Test Text Test Text.
Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.
Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag1]
[tag2]Test\'s Text Test Text Test Text Test Text.
Test Text Test Text Test "Text Test Text" Test Text Test Text.
Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.
Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag2]
...
...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end