import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\]]+)\\]([^\\[]+)\\[\\/\\1\\]";
final String string = "[tag1]Test's Text Test Text Test Text Test Text.\n\n"
+ "Test Text Test Text Test \"Text Test Text\" Test Text Test Text.\n\n"
+ "Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.\n\n"
+ "Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag1]\n\n"
+ "[tag2]Test's Text Test Text Test Text Test Text.\n\n"
+ "Test Text Test Text Test \"Text Test Text\" Test Text Test Text.\n\n"
+ "Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.\n\n"
+ "Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag2]\n\n"
+ "...\n\n"
+ "...\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}