using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(?P<amount>\d+(?:\.\d+)?)(?P<src>\w{3})";
string input = @":100.10us";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}