$re = '/:(?P<amount>\d+(?:\.\d+)?)(?P<src>\w{3})/m';
$str = ':100.10us';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);