package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):(?P<amount>\d+(?:\.\d+)?)(?P<src>\w{3})`)
var str = `:100.10us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}