# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((.)(?!$))/$1./gm;t' <<< "SONG
Another test Songtitle
SongTitle
So.la.la
What, if a comma or 123 or ??? would be in the name?
Special characters like # or ! or % or anything else?
"