using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.)(?!$))";
string substitution = @"$1.";
string input = @"SONG
Another test Songtitle
SongTitle
So.la.la
What, if a comma or 123 or ??? would be in the name?
Special characters like # or ! or % or anything else?
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}