#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((.)(?!$))"
Local $sString = "SONG" & @CRLF & _
"Another test Songtitle" & @CRLF & _
"SongTitle" & @CRLF & _
"So.la.la" & @CRLF & _
"What, if a comma or 123 or ??? would be in the name?" & @CRLF & _
"Special characters like # or ! or % or anything else?" & @CRLF & _
""
Local $sSubst = "$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)