$re = '/=?case\s([\w\.=\'\"><\(\)\]\[,]+\s)?when\s[\s\w\.=\'\"><\(\)\]\[,]+?\sthen\s[\s\w\.=\'\"><\(\)\]\[,]+?\s(else\s[\s\w\.=\'\"><\(\)\]\[,]+?\s)?end(\sAS\s)?/ix';
$str = 'case when i = 1 then \'temp\' else \'perm\' end col1,(select 1 from b) col2, Incident_Location, IncidentDate, ClinicalArea, Site, ClinicalIncident, Outcome, FileName, Status, DateClosed, What_Discuss, ID,PrimaryIncidentTypeID, Description, METCall, AFH_METCall,[abc]col2,[col3],col4="xyz",case when i in (\'a\',\'n\') then \'ss\' end [ads],AFH_METIn24Hr, MetTeam, IncidentInvolved, AFH_METCallReason, How_PrimTypeOth, HowRelateTypeOth, Threadnext, case jjlj when 99 then jjlda else ljfs end as col, col = case jjlj when 99 then jjlda else ljfs end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);