# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
=?case\s([\w\.='\"><\(\)\]\[,]+\s)?when\s[\s\w\.='\"><\(\)\]\[,]+?\sthen\s[\s\w\.='\"><\(\)\]\[,]+?\s(else\s[\s\w\.='\"><\(\)\]\[,]+?\s)?end(\sAS\s)?
"""
test_str = "case when i = 1 then 'temp' else 'perm' end col1,(select 1 from b) col2, Incident_Location, IncidentDate, ClinicalArea, Site, ClinicalIncident, Outcome, FileName, Status, DateClosed, What_Discuss, ID,PrimaryIncidentTypeID, Description, METCall, AFH_METCall,[abc]col2,[col3],col4=\"xyz\",case when i in ('a','n') then 'ss' end [ads],AFH_METIn24Hr, MetTeam, IncidentInvolved, AFH_METCallReason, How_PrimTypeOth, HowRelateTypeOth, Threadnext, case jjlj when 99 then jjlda else ljfs end as col, col = case jjlj when 99 then jjlda else ljfs end"
matches = re.finditer(regex, test_str, re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.