// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ix)=?case\s([\w\.='\"><\(\)\]\[,]+\s)?when\s[\s\w\.='\"><\(\)\]\[,]+?\sthen\s[\s\w\.='\"><\(\)\]\[,]+?\s(else\s[\s\w\.='\"><\(\)\]\[,]+?\s)?end(\sAS\s)?"#).unwrap();
let string = "case when i = 1 then 'temp' else 'perm' end col1,(select 1 from b) col2, Incident_Location, IncidentDate, ClinicalArea, Site, ClinicalIncident, Outcome, FileName, Status, DateClosed, What_Discuss, ID,PrimaryIncidentTypeID, Description, METCall, AFH_METCall,[abc]col2,[col3],col4=\"xyz\",case when i in ('a','n') then 'ss' end [ads],AFH_METIn24Hr, MetTeam, IncidentInvolved, AFH_METCallReason, How_PrimTypeOth, HowRelateTypeOth, Threadnext, case jjlj when 99 then jjlda else ljfs end as col, col = case jjlj when 99 then jjlda else ljfs end";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}