using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http[s]?:\/\/|\w+(?=\.)|\.\w+)";
string input = @"http://www.mail.yahoo.co.uk/blah/blah
https://test.test.again.mail.yahoo.com/blah/blah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}