const regex = /(http[s]?:\/\/|\w+(?=\.)|\.\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?:\\\/\\\/|\\w+(?=\\.)|\\.\\w+)', 'g')
const str = `http://www.mail.yahoo.co.uk/blah/blah
https://test.test.again.mail.yahoo.com/blah/blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}