re = /(http[s]?:\/\/|\w+(?=\.)|\.\w+)/
str = 'http://www.mail.yahoo.co.uk/blah/blah
https://test.test.again.mail.yahoo.com/blah/blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end