using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-z])(?!true|false)[a-z]+";
string input = @"true & G(asymbol) & false
true & G(asymbol) & anothersymbol
asymbolUbsymbol | false";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}