re = /(?<![a-z])(?!true|false)[a-z]+/m
str = 'true & G(asymbol) & false
true & G(asymbol) & anothersymbol
asymbolUbsymbol | false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end