$re = '/(?<![a-z])(?!true|false)[a-z]+/m';
$str = 'true & G(asymbol) & false
true & G(asymbol) & anothersymbol
asymbolUbsymbol | false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);