const regex = /^(.*\\.*\\[\w\d\&]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\\\.*\\\\[\\w\\d\\&]+)', 'gmi')
const str = `
USB\\VID_05B8&PID_3143\\5&95B63F&0&2··························:·USB-Eingabege
HID\\VID_046D&PID_C526&MI_01&COL01\\7&189E6BF7&0&0000·········:·HID-konformes·Benutzersteuergerõt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}