use strict;
my $str = '
USB\\VID_05B8&PID_3143\\5&95B63F&0&2··························:·USB-Eingabege
HID\\VID_046D&PID_C526&MI_01&COL01\\7&189E6BF7&0&0000·········:·HID-konformes·Benutzersteuergerõt';
my $regex = qr/^(.*\\.*\\[\w\d\&]+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}