$re = '/^(.*\\\\.*\\\\[\w\d\&]+)/mi';
$str = '
USB\\VID_05B8&PID_3143\\5&95B63F&0&2··························:·USB-Eingabege
HID\\VID_046D&PID_C526&MI_01&COL01\\7&189E6BF7&0&0000·········:·HID-konformes·Benutzersteuergerõt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);