package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BEGIN:VNOTE[\S\s]+?PRINTABLE:([\S\s]+?)D(CREATED:[\S\s]+?)T[\S\s]+?LAST-MODIFIED[\S\s]+?END:VNOTE`)
var str = `BEGIN:VNOTE
VERSION:1.1
BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Extracting text from a file is a common task in scripting and programming
DCREATED:20180304T203529
LAST-MODIFIED:20180304T203529
END:VNOTEBEGIN:VNOTE
VERSION:1.1
BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Most systems come pre-installed with Python
DCREATED:20190406T112342
LAST-MODIFIED:20190406T112342
END:VNOTEBEGIN:VNOTE
VERSION:1.1
BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:On Linux and macOS, the command to run the Python 3 interpreter is python3.
DCREATED:20170603T171656
LAST-MODIFIED:20170607T174906
END:VNOTEBEGIN:VNOTE
VERSION:1.1
BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Running Python with a file name will interpret that python program.
DCREATED:20190415T102154
LAST-MODIFIED:20190808T121123
END:VNOTEBEGIN:VNOTE
VERSION:1.1
BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Mauris nec maximus purus. Maecenas sit amet pretium tellus.
Quisque at dignissim lacus.
DCREATED:20190511T110151
LAST-MODIFIED:20190511T110151
END:VNOTEBEGIN:VNOTE
VERSION:1.1
BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:A Python program can read a text file using the built-in open() function.
DCREATED:20190501T074415
LAST-MODIFIED:20190511T130424
END:VNOTE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}