import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BEGIN:VNOTE[\\S\\s]+?PRINTABLE:([\\S\\s]+?)D(CREATED:[\\S\\s]+?)T[\\S\\s]+?LAST-MODIFIED[\\S\\s]+?END:VNOTE";
final String string = "BEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Extracting text from a file is a common task in scripting and programming\n"
+ "DCREATED:20180304T203529\n"
+ "LAST-MODIFIED:20180304T203529\n"
+ "END:VNOTEBEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Most systems come pre-installed with Python\n"
+ "DCREATED:20190406T112342\n"
+ "LAST-MODIFIED:20190406T112342\n"
+ "END:VNOTEBEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:On Linux and macOS, the command to run the Python 3 interpreter is python3.\n"
+ "DCREATED:20170603T171656\n"
+ "LAST-MODIFIED:20170607T174906\n"
+ "END:VNOTEBEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Running Python with a file name will interpret that python program.\n"
+ "DCREATED:20190415T102154\n"
+ "LAST-MODIFIED:20190808T121123\n"
+ "END:VNOTEBEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Lorem ipsum dolor sit amet, consectetur adipiscing elit.\n\n"
+ "Mauris nec maximus purus. Maecenas sit amet pretium tellus.\n\n"
+ "Quisque at dignissim lacus.\n"
+ "DCREATED:20190511T110151\n"
+ "LAST-MODIFIED:20190511T110151\n"
+ "END:VNOTEBEGIN:VNOTE\n"
+ "VERSION:1.1\n"
+ "BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:A Python program can read a text file using the built-in open() function.\n"
+ "DCREATED:20190501T074415\n"
+ "LAST-MODIFIED:20190511T130424\n"
+ "END:VNOTE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}