import re
regex = re.compile(r"BEGIN:VNOTE[\S\s]+?PRINTABLE:([\S\s]+?)D(CREATED:[\S\s]+?)T[\S\s]+?LAST-MODIFIED[\S\s]+?END:VNOTE", flags=re.MULTILINE)
test_str = ("BEGIN:VNOTE\n"
"VERSION:1.1\n"
"BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Extracting text from a file is a common task in scripting and programming\n"
"DCREATED:20180304T203529\n"
"LAST-MODIFIED:20180304T203529\n"
"END:VNOTEBEGIN:VNOTE\n"
"VERSION:1.1\n"
"BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Most systems come pre-installed with Python\n"
"DCREATED:20190406T112342\n"
"LAST-MODIFIED:20190406T112342\n"
"END:VNOTEBEGIN:VNOTE\n"
"VERSION:1.1\n"
"BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:On Linux and macOS, the command to run the Python 3 interpreter is python3.\n"
"DCREATED:20170603T171656\n"
"LAST-MODIFIED:20170607T174906\n"
"END:VNOTEBEGIN:VNOTE\n"
"VERSION:1.1\n"
"BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Running Python with a file name will interpret that python program.\n"
"DCREATED:20190415T102154\n"
"LAST-MODIFIED:20190808T121123\n"
"END:VNOTEBEGIN:VNOTE\n"
"VERSION:1.1\n"
"BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:Lorem ipsum dolor sit amet, consectetur adipiscing elit.\n\n"
"Mauris nec maximus purus. Maecenas sit amet pretium tellus.\n\n"
"Quisque at dignissim lacus.\n"
"DCREATED:20190511T110151\n"
"LAST-MODIFIED:20190511T110151\n"
"END:VNOTEBEGIN:VNOTE\n"
"VERSION:1.1\n"
"BODY;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:A Python program can read a text file using the built-in open() function.\n"
"DCREATED:20190501T074415\n"
"LAST-MODIFIED:20190511T130424\n"
"END:VNOTE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")