import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m-s)^[^\"\\r\\n]*?\"note\"\\h*:\\h*\"[^\"\\r\\n]*?\\d+[^\"\\r\\n]*\".*";
final String string = " \"note\" : \"\",\n"
+ " \"note\" : \"Here is my note\",\n"
+ " \"note\" : \"My note $%$\",\n"
+ " \"note\" : \"Created bug 14569 in the system\",\n"
+ " \"note\" : \"Another beautiful note\",\n"
+ " \"note\" : \"@#$%#@%dgdeg\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}