const regex = /(?m-s)^[^"\r\n]*?"note"\h*:\h*"[^"\r\n]*?\d+[^"\r\n]*".*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m-s)^[^"\\r\\n]*?"note"\\h*:\\h*"[^"\\r\\n]*?\\d+[^"\\r\\n]*".*', 'g')
const str = ` "note" : "",
"note" : "Here is my note",
"note" : "My note \$%\$",
"note" : "Created bug 14569 in the system",
"note" : "Another beautiful note",
"note" : "@#\$%#@%dgdeg"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}